Adobe issues critical vunerability in Adobe Flash Player

Two alerts in less than 24 hours?

Keep calm and install Google Chrome. That is my best advice at the moment.

Hours ago, Adobe issued a priority 1 (really bad) alert for its Flash Player as it has cross platform vulnerabilities that could allow a compromised website to run extra code on an unpatched computer which is pretty much every system including all Windows, Apple Mac (OSX) and Linux Systems that have flash players older than today.

This is going to be a fast update so everyone is advised to at least install (and use) Google Chrome until Flash Player has been updated. Check the links below..

Google Chrome

Adobe Flash Player